Intel DP45SG and Lian-Li PC-C33B HTPC

I recently built a new home theater PC using an Intel DP45SG motherboard and a Lian-Li PC-C33B case.
I am replacing my existing HTPC that appears to be not quite compatible with Windows 7.
The existing machine uses a Lian-Li PC-C31B case, Intel DG33TL motherboard, and ATI Sapphire HD 2600XT video card.
I started documenting the new machine installation, but the new case was on backorder, and I had all components except the new case, so I tried the HD 5750 card in the old machine.
The results were not so good, skip ahead and read about the display driver that stops responding, or read on.
Some background on the old machine…
The HD 2600XT GPU fan was very load, too loud for a HTPC.
I replaced the stock HD 2600XT fan with a Zalman VF900-Cu fan, and this made it much quieter.

The stock Lian-Li case fans reported erratic rotational speeds with the DG33TL fan sensors.
I replaced the stock case fans with Antec Tri-Cool fans, and the rotational speeds were reported correctly.

Since upgrading from Vista to Windows 7, the machine does not stay asleep, it will go to sleep, then within a few seconds wake up again.
The DG33TL board is also missing some Windows 7 drivers, specifically the SMBus driver from Vista has to be installed in compatibility mode.
I am a great fan of Lian-Li cases, they are light, extremely well made, and very stylish.
I have owned several Lian-Li cases, including a PC-V2100B Plus II, PC-C31B, PC-A06B, PC-60FWB, PC-B71B, and the latest the PC-C33B.
I chose to replace my PC-C31B case with the Lian-Li PC-C33B case because I wanted to use an ATX size motherboard, and the PC-C31B case only accommodates Micro-ATX boards.
The PC-C31 was succeeded by the PC-C32, and the PC-C32 was succeeded by the PC-C33, so the cases are very similar.
On the outside the PC-C31B and the PC-C33B look nearly identical, on the inside the PC-C33B layout is more spacious, and better laid out.
The one thing I wish the PC-C33B had retained was the hidden CD-ROM covers, it makes for a neater appearance.

I am not particular to any one brand of motherboard, but I normally use either Asus, Gigabyte, or Intel.
I chose the Intel DP45SG because it has already undergone several revisions to iron out the kinks, and it provided the basic functionality I needed without any additional bells and whistles I don’t need.
With the release of the i5 and i7 processors, and P55 chipsets, I chose to stay with the P45 chipset because the Core processors and dual-channel DDR3 memory is is reasonably cheap.
I went with an Intel Core 2 Quad Q9650 3GHz processor, and Kingston KHX1333C7D3K2 memory.
I haven’t used NVidia graphic cards in a long time, compared to the ATI HD series cards, the NVidia equivalents are just too expensive.
I chose the ATI Sapphire HD 5750 because it has an HDMI connecter, thus no need for a DVI to HDMI adapter, and it is quiet.
I could have gone with the 5770, but the 5750 is sufficient for my needs, primarily watching movies, and is quieter and uses less power.
The DP45SG board has three fan connectors, Front, Rear, and AUX.
The Lian-Li PC-C33B case has three fans, two rear 80mm 1200rpm fans, and a 140mm 1200rpm HDD cage fan.
I connected the front and rear fan connectors to the two rear 80mm fans, and the AUX connector to the 140mm HDD cage fan.
The DP45SG BIOS supports temperature feedback fan control.
But with this option enabled, the two stock Lian-Li 80mm rear fans would not run at all.
If I disable fan control, meaning the fans are on all the time, the fans worked fine.
I replaced the two stock fans with Scythe S-Flex 80mm 1500rpm fans, and they worked perfectly, and silently, at low RPM.
When I ordered the 80mm fans, I also ordered a Scythe Kaze Maru 140mm 1200rpm fan to replace the stock Lian-Li 140mm fan.
When I tried to install it, I realized that this was really a 120mm fan, or at least the mounting holes were for a 120mm fan.
There is a little piece of text on Scythe site that I missed:
“*Only Compatible to 120mm fan Slots!!*”
I left the stock Lian-Li 140mm fan and it works fine, maybe a little loud, but I don’t have a suitable replacement.
While searching for information on the fans not running, I came across the following on the Intel Desktop Control Center site:
“The Intel Desktop Board DP45SG was updated to revision AA# E27733-405 to add an alternate hardware monitoring and fan control ASIC.”
I have the 405 revision board, but without access to an older board, I really don’t know what changed.
I used Lavalys EVEREST to monitor the fan speeds from within Windows, at idle the 80mm fans run around 410rpm, and the 140mm fan at around 1100rpm.
EVEREST does however report the wrong fan labels; System should be AUX, Chassis should be Front, and Power Supply should be Rear.
I posted the mismatch on the EVEREST forum, I hope they fix it at some point.
The DP45SG board requires three power connectors, the normal 2×12 pin, a 2×2 pin, and a 4×1 pin.
I’ve seen other Intel boards requiring the additional 2×2, but this is the first board I’ve seen that requires the 2×2 and a 4×1.
I previously had a problem with an Intel S5000PSL board that required the extra 2×2, but the Corsair HX 850W PSU did not include the 2×2 pin connector, I had to buy a 4×1 to 2×2 converter for this board.
Fortunately the Thermaltake Toughpower 650W PSU I used for this build had all the required connectors.
On running the system I noticed one abnormality reported in the eventlog:
“The platform firmware has corrupted memory across the previous system power transition. Please check for updated firmware for your system.”

Searching I found several people reporting this event on a variety of hardware.
I did find this document from Microsoft on the topic, and they have this to say:
“During Windows development, we observed some systems that corrupt the lowest 1 MB of physical memory during a sleep transition. We traced the memory corruption to code defects in platform firmware. Because of the pervasiveness of the problem in the industry and the desire for reliable sleep transitions, Windows no longer stores operating system code and data in the lowest 1 MB of physical memory.”
Everything is now up and running with Windows 7 Ultimate x64.
The new HTPC replaced the old one in our living room, all that is left to do are the final tweaks for power profiles, remote control only login, codec’s, etc.
I normally use Media-Portal for a media frontend, but I’ve been playing with XBMC, and I think I’ll give that a try instead.
The new machine is not as quiet as the old one, I suspect it is because of the 140mm fan, and the additional ventilation holes on the side of the case.
I’ll keep on looking for a quieter 140mm fan, and maybe add some sound insulation, but for now it is good enough.

Problems with the old HTPC and the new HD 5750 card…

The new Lian-Li PC-C33B case was on backorder, so while I had all components except the case, I tried the HD 5750 in my current machine.
The HD 2600XT worked out of the box with the drivers included with Windows 7 Ultimate x64.
I replaced the HD 2600XT with the HD 5750, on reboot the display reverted to standard VGA, and 640×480 resolution.
I had to download and install the ATI Catalyst 9.11 drivers.
One would think that a VGA driver installer would be designed to fit on a screen that does not have VGA drivers installed, i.e. fit on a 640×480 resolution screen?
But no, with the standard VGA resolution the ATI driver installer window does not fit on the screen.
In order to install the drivers I had to move the window using the keyboard, see what the keyboard accelerator shortcut for a UI element is, or see where the tab focus is.
Really ATI, this seems like such a basic thing.

After the driver was installed I noticed the screen underscanned, meaning there is a black border or unused space around the screen.
I know from past experience that there is an overscan option in the Catalyst Control Center, but when I looked where I remember the setting to be, I could not find it.
I also noticed that the control panel menu layout has completely changed, and not for the better.
After some searching I found that you have to go to your displays panel, then click on the little arrow on the small monitor window, not the big monitor window.

Then adjust the overscan.
It was interesting to note that the default value, in Windows 7 at least, is to underscan.
When I first hooked up my HTPC running Vista to my plasma TV, fixing the overscan is the first thing I tried to do so that I could see the entire desktop.
Usability wise it makes sense to have a default that will let you see the entire desktop, vs. a default that cuts of parts of the screen.
My preference is to just let the TV overscan and not let the graphic card scale the output to compensate for overscan.
The 1:1 ratio, i.e. no scaling, results in better graphic quality, especially noticeable with fonts, at the expense of the desktop edge not being visible.
As I was searching for information on the new CCC options, I found many people complaining about CCC, and recommending using ATI Tray Tools instead.
I’ve never used it myself, but it is good to know there are alternatives.

Now that the driver was installed, another problem presented itself.
Every minute or so the screen would freeze, then a few seconds later it would start responding again, and windows would report:
“Display driver stopped responding and has recovered”.
When this happens the screen would freeze, the mouse cursor would still work, sometimes there would be squiggly lines on the screen, and other times it would go gray.
On two occasions the screen did not recover and I had to do a hard reset.

Analyzing the dump file with WinDbg, the problem is related to TDR, VIDEO_TDR_TIMEOUT_DETECTED, GRAPHICS_DRIVER_TDR_TIMEOUT.
MSDN has the following to say:
“This indicates that the display driver failed to respond in a timely fashion.”
Searching I found many people complaining about this problem with Windows 7 x64 and the 57xx cards, see here, here, and here.
A common response was to wait for the new Catalyst 9.12 drivers.
I was still using the 9.11 drivers, so I waited, and when released, I installed 9.12, but the same problem.
The ATI forum reported the same, the 9.12 driver, and the 9.12 driver hotfix does not address this problem.
The 5750 is still not working with the DG33TL board, but, fortunately it does work in the DP45SG board.
I replaced the HD 5750 with the old HD 2600XT, and the old machine is working fine again.
Advertisements

5 thoughts on “Intel DP45SG and Lian-Li PC-C33B HTPC”

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s